USB-C-Ärger mit dem Raspberry Pi 4

Zur Stromversorgung des Raspberry Pi 4 brauchen Sie ein USB-C-Kabel. Am anderen Ende muss sich (laut Raspberry-Pi-Foundation) ein Netzteil mit mind. 12,5 Watt befinden; empfohlen werden 15 W.

So weit, so gut. Nur: Nicht jede Kombination aus Netzteil und Kabel funktioniert, auch wenn am Anfang genug Leistung und am Ende USB-C ist …

Update 10.7.2019: Die Raspberry Pi Foundation hat den Fehler nun offiziell bestätigt. In ein paar Monaten soll es eine Revision der Platine geben. Quelle heise.de

Funktioniert gut: Notebook-Netzteil

Notebook-Netzteil 65 W, bei dem das USB-C-Kabel direkt mit dem Netzteil verbunden ist (d.h., beim Netzteil gibt es keine Buchsen).

Notebook-Netzteil ohne Buchse direkt USB-C

(65 W sind überdimensioniert, ich weiß. Bei mir liegen aber gerade keine anderen USB-C-Netzteile herum, und die vielen Watt stören ja nicht. Der Raspberry Pi nimmt nur, was er braucht, typischerweise 4 bis 8 W. Dementsprechend wird das Netzteil nicht einmal warm.)

Funktioniert gut: Netzteil mit USB-A-Buchse, Kabel USB-A zu USB-C

  • Smartphone-Netzteil 10 W mit USB-A-Buchse
  • Kabel USB-A (Netzteil) zu USB-C (Raspberry Pi 4)
Netzteil USB-A, Kabel USB-A -> USB-C

Funktioniert halbwegs: Netzteil mit USB-C-Buchse, Adapter zu USB-A, Kabel USB-A zu USB-C

  • Netzteil 15 W mit USB-C-Buchse
  • Adapter USB-C zu USB-A
  • Kabel USB-A zu USB-C
Netzteil mit USB-C-Buchse, Adapter USB-C -> USB-A, Kabel USB-A -> USB-C

Diese Kombination ist aus einer Notlösung heraus entstanden. Beim Ausprobieren habe ich kein USB-C-zu-USB-C-Kabel gefunden, also habe ich mich mit dem Adapter beholfen. Allerdings kommt beim Raspberry Pi zu wenig Leistung an (oder eine zu niedrige Spannung). Der Raspberry Pi bootet, zeigt aber undervolted-Nachrichten (dmesg) und am Bildschirm den gelben Blitz als Indikator für Probleme mit der Stromversorgung an.

Funktioniert gar nicht: Netzteil mit USB-C-Buchse, Kabel USB-C zu USB-C

  • Netzteil 15 W mit USB-C-Buchse
  • Kabel USB-C zu USB-C

Eigentlich hatte ich geplant, meinen Raspberry Pi so zu betreiben. Aber leider funktioniert das überhaupt nicht, beim Raspberry Pi leuchtet nicht einmal eine LED.

Netzteil mit USB-C-Buchse, Kabel USB-C/USB-C

Die Ursache des Problems ist laut Tyler Ward, dass der USB-C-Anschluss des Raspberry Pi 4 nicht korrekt ausgeführt ist: Mit ‚dummen‘ (passiven) USB-C-Kabeln funktioniert das Laden. Mit ‚intelligenten‘ (aktiven) Kabeln glaubt das Netzteil hingegen, es wäre ein Audio-Device angeschlossen, und das Laden funktioniert nicht.

Quellen

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

Wenn Sie hier einen Kommentar absenden, erklären Sie sich mit der folgenden Datenschutzerklärung einverstanden.